Gönderen Konu: 13.09.2016 Güncelleme Hatası  (Okunma sayısı 2072 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı sparus

  • Devamlı Üye
  • ***
  • İleti: 136
  • Teşekkür: +0/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
13.09.2016 Güncelleme Hatası
« : 13 Eylül 2016, 16:14:10 »
KDE kullandığım için konuyu buraya açayım dedim. Başka bir başlık altında yazacaktım ancak forum beni yeni bir konu açmam için uyardığı için açıyorum konuyu.

Bugün bir güncelleme geldi ancak hata verip duruyor. Manjaro foruma baktığımda Catalyst ile ilgili bir sorun olduğu kanısına kapıldım. Ancak önerilmiş bir çözüm göremedim. O nedenle sorunun çözümü için bu bayram günü sizlere danışmak istedim.

Sorunun çıktısı aşağıda.  ,

Kod: [Seç]
:: Sistem güncellemesi başlatılıyor...
:: akonadi-contact paketini extra/akonadi-contacts ile değiştirmek ister misiniz? [E/h]
:: grantlee-qt5 paketini extra/grantlee ile değiştirmek ister misiniz? [E/h]
:: libdbus paketini core/dbus ile değiştirmek ister misiniz? [E/h]
:: prison-frameworks paketini extra/prison ile değiştirmek ister misiniz? [E/h]
:: quazip-qt5 paketini extra/quazip ile değiştirmek ister misiniz? [E/h]
paket bağımlılıkları çözümleniyor...
varsa paketler arası çakışmalara bakılıyor...
uyarı: 'xorg-server-common' hedef listesindeki 'catalyst-server' ile çakıştığı için kaldırıldı
uyarı: 'xorg-server' hedef listesindeki 'catalyst-server' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-synaptics' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-acecad' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-elographics' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-evdev' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-joystick' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-keyboard' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-mouse' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-void' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
uyarı: 'xf86-input-wacom' hedef listesindeki 'catalyst-input' ile çakıştığı için kaldırıldı
:: kldap, kio-pim ile çakışıyor. kio-pim paketinin kaldırılmasını istiyor musunuz? [e/H]
hata: çözülemeyen paket çakışmaları bulundu
hata: işlem hazırlığı başarısız oldu (çakışan bağımlılıklar)
:: kldap ve kio-pim çakışıyor

Memurus memurusous (Lineus 657)

Çevrimdışı tulliana

  • az laf, çok iş...
  • Proje Sorumlusu
  • Gelişmiş Üye
  • *****
  • İleti: 2995
  • Teşekkür: +120/-0
    • http://archman.org
  • Dağıtım / Distribution: Archman Linux
  • Sürüm / Release: devel
  • Ekran Kartı - Graphic Card: NVIDIA
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #1 : 13 Eylül 2016, 16:46:42 »
kldap ve kio-pim paketini ya da birini kaldırıp tekrar güncellemeyi deneyin
http://archman.org - Bizi bilen iyi bilir, bilmeyen de kendi gibi bilir.!

Çevrimdışı sparus

  • Devamlı Üye
  • ***
  • İleti: 136
  • Teşekkür: +0/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #2 : 13 Eylül 2016, 17:16:47 »
Maalesef hem tek tek paketleri kaldırırken hem de ikisini birden kaldırırken aynı sonucu alıyorum. Paketler kaldırılamıyor ve güncellemem malesef gerçekleşmiyor.

Kod: [Seç]
[[email protected] ~]$ sudo pacman -R kldap kio-pim
paket bağımlılıkları araştırılıyor...
hata: işlem hazırlığı başarısız oldu (bağımlılıklar sağlanamadı)
:: kmail:  'kio-pim' bağımlılığı sağlanamadı kio-pim kaldırılıyor
:: libkdepim:  'kldap' bağımlılığı sağlanamadı kldap kaldırılıyor
Memurus memurusous (Lineus 657)

Çevrimdışı ata

  • Gelişmiş Üye
  • *****
  • İleti: 2133
  • Teşekkür: +39/-0
  • yuvarlanıp gidiyoruz
  • Dağıtım / Distribution: Arch Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Özgür Yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #3 : 13 Eylül 2016, 17:20:49 »
Kod: [Seç]
sudo pacman -Rsn kldap kio-pim
dene fakat anlaşılan kullandığın kmail ve libkdepim daha önce kaldırılmalı
« Son Düzenleme: 13 Eylül 2016, 17:22:37 Gönderen: ata »
Suskunluğum asaletimdendir,her lafa verilecek cevabım var. Ama bir lafa bakarım laf mı ? diye bir de söyleyene bakarım adam mı ? diye

                        

Çevrimdışı sparus

  • Devamlı Üye
  • ***
  • İleti: 136
  • Teşekkür: +0/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #4 : 13 Eylül 2016, 17:32:20 »
Haklısınız

Kod: [Seç]
[[email protected] ~]$ sudo pacman -Rsn kldap kio-pim
[sudo] password for mehmet:
paket bağımlılıkları araştırılıyor...
hata: işlem hazırlığı başarısız oldu (bağımlılıklar sağlanamadı)
:: kmail:  'kio-pim' bağımlılığı sağlanamadı kio-pim kaldırılıyor
:: libkdepim:  'kldap' bağımlılığı sağlanamadı kldap kaldırılıyor
Memurus memurusous (Lineus 657)

Çevrimdışı ata

  • Gelişmiş Üye
  • *****
  • İleti: 2133
  • Teşekkür: +39/-0
  • yuvarlanıp gidiyoruz
  • Dağıtım / Distribution: Arch Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Özgür Yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #5 : 13 Eylül 2016, 17:49:04 »
Kod: [Seç]
sudo pacman -Rsn libkdepim
Kod: [Seç]
sudo pacman -Rsn kldap
şeklinde bir dene sonrasında güncellemeye çalış.
Suskunluğum asaletimdendir,her lafa verilecek cevabım var. Ama bir lafa bakarım laf mı ? diye bir de söyleyene bakarım adam mı ? diye

                        

Çevrimdışı sparus

  • Devamlı Üye
  • ***
  • İleti: 136
  • Teşekkür: +0/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #6 : 13 Eylül 2016, 17:56:33 »
Sonsuz bir döngüye gireceğiz gibi. :)

Kod: [Seç]
[[email protected] ~]$ sudo pacman -Rsn libkdepim
[sudo] password for mehmet:
paket bağımlılıkları araştırılıyor...
hata: işlem hazırlığı başarısız oldu (bağımlılıklar sağlanamadı)
:: mailimporter:  'libkdepim' bağımlılığı sağlanamadı libkdepim kaldırılıyor
:: pimcommon:  'libkdepim' bağımlılığı sağlanamadı libkdepim kaldırılıyor
[[email protected] ~]$ sudo pacman -Rsn kldap
paket bağımlılıkları araştırılıyor...
hata: işlem hazırlığı başarısız oldu (bağımlılıklar sağlanamadı)
:: kio-pim:  'kldap' bağımlılığı sağlanamadı kldap kaldırılıyor
:: libkdepim:  'kldap' bağımlılığı sağlanamadı kldap kaldırılıyor

Belki bir kaç güne bu sorun düzeltilir. O zaman denemek işe yarayabilir.
Memurus memurusous (Lineus 657)

Çevrimdışı tulliana

  • az laf, çok iş...
  • Proje Sorumlusu
  • Gelişmiş Üye
  • *****
  • İleti: 2995
  • Teşekkür: +120/-0
    • http://archman.org
  • Dağıtım / Distribution: Archman Linux
  • Sürüm / Release: devel
  • Ekran Kartı - Graphic Card: NVIDIA
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #7 : 13 Eylül 2016, 19:24:32 »
-R parametresinden sonra girdi eklemeyin. Bağımlılık zorunlu ise kendisi ekleyecektir zaten. Siz parametreye eklerseniz zincir etkisini tetiklemiş olursunuz.
http://archman.org - Bizi bilen iyi bilir, bilmeyen de kendi gibi bilir.!

Çevrimdışı sparus

  • Devamlı Üye
  • ***
  • İleti: 136
  • Teşekkür: +0/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #8 : 13 Eylül 2016, 19:33:15 »
İlginize teşekkür ederim ancak -R parametresinden sonra girdi eklemesem bile bir başka bağımlılık ortaya çıkıyor ve kaldırılmıyor. Tahmin ediyorum ki (Daha önceki tecrübelere dayanarak)  kldap ve kio-pim çakışıyor sorununu halletsek bile muhtemelen başka bir sorun ortaya çıkacak. Bu sefer başka bir bağımlılık ortaya çıkacak. Bilemiyorum nasıl düzelir bu? Yukarıda dediğim gibi geliştiriciler belki sorunu fark ederek başka bir güncelleme ile sorunu çözerler. Daha önce öyle olmuştu. Başka fikirleriniz varsa elbette denemeye hazırım.
Memurus memurusous (Lineus 657)

Çevrimdışı ata

  • Gelişmiş Üye
  • *****
  • İleti: 2133
  • Teşekkür: +39/-0
  • yuvarlanıp gidiyoruz
  • Dağıtım / Distribution: Arch Linux
  • Ekran Kartı - Graphic Card: ATI
  • Ekr. Kartı Sür. Graph.Dri: Özgür Yazılım
Ynt: 13.09.2016 Güncelleme Hatası
« Yanıtla #9 : 13 Eylül 2016, 19:39:53 »
Başka paketlerce kullanılmayan bağımlılıklarıyla birlikte bir paketi kaldırmak
-Rs

Pacman , kurulu paketlerin ayar dosyalarını .pacsave şeklinde saklar. Bir paketi ütün ayar dosyalarıyla beraber kaldırmak için
-Rn

Dolayısı ile sorun olmayacaktır.  Ama -Rsnc dersek sorun olacaktır.
Suskunluğum asaletimdendir,her lafa verilecek cevabım var. Ama bir lafa bakarım laf mı ? diye bir de söyleyene bakarım adam mı ? diye