Gönderen Konu: [Çözüldü]ATI Catalyst Çalışmıyor  (Okunma sayısı 22026 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

mehmet280

  • Ziyaretçi
[Çözüldü]ATI Catalyst Çalışmıyor
« : 19 Şubat 2013, 10:25:28 »
Sistem başlangıçta mhwd-catalyst kurdu. Ben ATI'nin catalyst 13.1'ini kurmak istedim ve karşıma farklı versiyonlar çıktı. Oradaki 34, 37 gibi sayıların kernel versiyonuyla alakalı olduğunu düşündüğümden
Kod: [Seç]
uname -a yazarak
Kod: [Seç]
Linux manjaro 3.4.31-1-MANJARO #1 SMP PREEMPT Fri Feb 15 20:25:45 CET 2013 x86_64 GNU/Linux çıktısını aldım. Kernel versiyonu 3.4.31 olunca linux34-catalyst kurdum. Onunla birlikte catalyst-utils paketi de kuruldu.

Uygulama menüsünden>Ayarlar>AMD Catalyst Control Center'a tıkladığımda ise

Catalyst Control Center Linux sürümü başlatılırken bir sorunla karşılaşıldı.  Aşağıdaki sebeplerden birinden dolayı oluşmuş olabilir.

Hiçbir AMD grafik sürücüsü kurulmadı veya AMD sürücüsü düzgün çalışmıyor.
Lütfen AMD donanımınıza uygun AMD sürücüsünü kurun, veya aticonfig'i kullanarak yapılandırın.
uyarısı alıyorum.

Çevrimdışı decent

  • Gelişmiş Üye
  • *****
  • İleti: 829
  • Teşekkür: +12/-0
  • Dağıtım / Distribution: ArchLinux
  • Sürüm / Release: *
  • Ekran Kartı - Graphic Card: NVIDIA
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Re: ATI Catalyst Çalışmıyor
« Yanıtla #1 : 19 Şubat 2013, 10:46:44 »
Kod: [Seç]
fglrxinfo
Kod: [Seç]
lspci | grep VGAve
Kod: [Seç]
mhwd -li
ne diyor ?

mehmet280

  • Ziyaretçi
Re: ATI Catalyst Çalışmıyor
« Yanıtla #2 : 19 Şubat 2013, 10:52:53 »
Kod: [Seç]
$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD CEDAR
OpenGL version string: 2.1 Mesa 9.0.2

Kod: [Seç]
$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series]

Kod: [Seç]
$ mhwd -li
> Installed PCI configs:

--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
             video-ati            2012.09.18                true            PCI


Warning: No installed USB configs!

Çevrimdışı decent

  • Gelişmiş Üye
  • *****
  • İleti: 829
  • Teşekkür: +12/-0
  • Dağıtım / Distribution: ArchLinux
  • Sürüm / Release: *
  • Ekran Kartı - Graphic Card: NVIDIA
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Re: ATI Catalyst Çalışmıyor
« Yanıtla #3 : 19 Şubat 2013, 11:07:03 »
O halde yükleme yapalım:
#
Kod: [Seç]
pacman -Sy linux34-catalyst lib32-catalyst-utils
Aşağıdaki komutu yürütelim
#
Kod: [Seç]
aticonfig --initial -fve sistemi yeniden başlatalım:
#
Kod: [Seç]
reboot
[bilgi][size=150]#[/size] işareti, verilen komutun yönetici -root- hakları ile yürütülmesi gerektiğini belirtmek içindir.[/bilgi]

mehmet280

  • Ziyaretçi
Re: ATI Catalyst Çalışmıyor
« Yanıtla #4 : 19 Şubat 2013, 11:26:18 »
Hocam yeniden başlattığımda başlangıç ekranı gelmedi. Ekran siyah. Ben de Mint'ten yazıyorum şu an.

Çevrimdışı decent

  • Gelişmiş Üye
  • *****
  • İleti: 829
  • Teşekkür: +12/-0
  • Dağıtım / Distribution: ArchLinux
  • Sürüm / Release: *
  • Ekran Kartı - Graphic Card: NVIDIA
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Re: ATI Catalyst Çalışmıyor
« Yanıtla #5 : 19 Şubat 2013, 11:38:59 »
Mint üzerinden Manjaro kurulu bölüme ulaş ve varsa aşağıdaki dosyayı yönetici hakları ile sil:
[c]/etc/X11/xorg.conf[/c]

Manjaroyu açıp aşağıdaki komutları yürüterek yeniden başlat:
Kod: [Seç]
sudo mhwd-kernel linux37 lib32-catalyst-utils
Kod: [Seç]
sudo reboot
Masaüstüne ulaşamıyorsan [c]Ctrl+Alt+F1[/c] veya ...F2... kullanabilirsin.

mehmet280

  • Ziyaretçi
Re: ATI Catalyst Çalışmıyor
« Yanıtla #6 : 19 Şubat 2013, 11:59:26 »
Masaüstü geldi ama ATI Catalyst'i yine açamıyorum.

Bu arada sistemde hem linux34 hem de 37 yüklü. O eski 34'leri kaldıracak mıyım?

uname -a çıktısı da

Kod: [Seç]
Linux manjaro 3.4.31-1-MANJARO #1 SMP PREEMPT Fri Feb 15 20:25:45 CET 2013 x86_64 GNU/Linux

Çevrimdışı decent

  • Gelişmiş Üye
  • *****
  • İleti: 829
  • Teşekkür: +12/-0
  • Dağıtım / Distribution: ArchLinux
  • Sürüm / Release: *
  • Ekran Kartı - Graphic Card: NVIDIA
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Re: ATI Catalyst Çalışmıyor
« Yanıtla #7 : 19 Şubat 2013, 19:56:50 »
Sistemi 3.7.? çekirdek ile başlatarak [c]linux34[/c] paketlerini kaldırıp sistemi yeniden başlatabilirsin.

Şu çıktıya da bakalım:
Kod: [Seç]
sudo pacman -Q linux37-catalyst

mehmet280

  • Ziyaretçi
Re: ATI Catalyst Çalışmıyor
« Yanıtla #8 : 19 Şubat 2013, 21:32:13 »
Sistemi 3.7.... çekirdek ile başlatmak için ayrı birşey yapmam mı gerekiyor?

Daha önce Mint'te kernel güncellemesi yaptığım zaman Grub ekranında Old Linux Mint tarzı birşey görmüştüm. Bunda öyle birşey yok.

linux34 paketlerini kaldırsam kernel 3.7 den mi başlayacak?

Ayrıca
Kod: [Seç]
sudo pacman -Q linux37-catalyst çıktısı

Kod: [Seç]
linux37-catalyst 13.1-3 şeklinde.

Çevrimdışı cumali

  • Gelişmiş Üye
  • *****
  • İleti: 1785
  • Teşekkür: +2/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Masaüstü / Desktop Environment: Openbox
  • Ekran Kartı - Graphic Card: INTEL
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Re: ATI Catalyst Çalışmıyor
« Yanıtla #9 : 19 Şubat 2013, 22:04:07 »
Alıntı yapılan: "mehmet280"
Sistemi 3.7.... çekirdek ile başlatmak için ayrı birşey yapmam mı gerekiyor?

Grub ekranında Manjaro 3.7... şeklinde bir yazı göremiyorsanız yada eski 3.4 çekirdegi yer alıyorsa o zaman şu komutu yürütün;
Kod: [Seç]
sudo mhwd-kernel linux37Ama önce @decent'in ATI konusunda söyleyeceklerine kulak verin.