Gönderen Konu: [Çözüldü]Ses Kartı Sorunu  (Okunma sayısı 3319 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı 1910

  • Yeni Üye
  • *
  • İleti: 8
  • Teşekkür: +0/-0
[Çözüldü]Ses Kartı Sorunu
« : 25 Temmuz 2013, 17:51:57 »
Bilgisayarın, her yeni açılışından sonra sesi alabilmek için ses denetimine girerek, kartımı seçmek zorunda kalıyorum.
Ses kartımı nasıl ön tanımlı hale getirebilirim?

Çevrimdışı ufuk

  • Yeni Üye
  • *
  • İleti: 49
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #1 : 25 Temmuz 2013, 21:39:32 »
HDMI ses çıkış aygıtınız var mı?
Kod: [Seç]
lsmod|grep hdmiçıktısını paylaşır mısınız?

Çevrimdışı 1910

  • Yeni Üye
  • *
  • İleti: 8
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #2 : 25 Temmuz 2013, 21:54:03 »
Evet. Buyrun.
Kod: [Seç]
[[email protected] ~]$ lsmod|grep hdmi
snd_hda_codec_hdmi     25918  1
snd_hda_codec         125545  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_analog
snd_pcm                62851  5 snd_ac97_codec,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_emu10k1x
snd                    44486  31 snd_ac97_codec,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_emu10k1x,snd_hda_codec_analog
[[email protected] ~]$

Çevrimdışı ufuk

  • Yeni Üye
  • *
  • İleti: 49
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #3 : 26 Temmuz 2013, 01:07:56 »
Kod: [Seç]
cat /proc//asound/modules çıktısında 0. cihaz varsayılan, 1. ise ikinci sırada yer alan şeklinde görünecek. Çıktıya göre conf dosyası oluşturacağız. Bende tek ses çıkışı olduğu için test edemiyorum ancak çözüm olacaktır.

Bende
Kod: [Seç]
[[email protected] ~]$ cat /proc//asound/modules
 0 snd_hda_intel
[[email protected] ~]$

Çevrimdışı 1910

  • Yeni Üye
  • *
  • İleti: 8
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #4 : 26 Temmuz 2013, 01:46:55 »
Komutun çıktısı şu şekilde.
Kod: [Seç]
[[email protected] ~]$ cat /proc//asound/modules
 0 snd_hda_intel
 1 snd_emu10k1x
 2 snd_hda_intel
[[email protected] ~]$

Çevrimdışı ufuk

  • Yeni Üye
  • *
  • İleti: 49
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #5 : 26 Temmuz 2013, 04:22:06 »
Yönetici hakkı ile
Kod: [Seç]
/etc/modprobe.d/klasöründe bir boş dosya oluşturup ismine örneğin
Kod: [Seç]
alsa-base.confdeyin. .conf uzantılı olmalı. İçine de
Kod: [Seç]
options snd slots=snd_emu10k1x,snd_hda_intel
options snd_emu10k1x index=0
options snd_hda_intel index=1
Sistemi yeniden başlatıp kontrol edin.

Çevrimdışı 1910

  • Yeni Üye
  • *
  • İleti: 8
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #6 : 26 Temmuz 2013, 05:38:06 »
Kod: [Seç]
[[email protected] ~]$ cat /proc//asound/modules
 0 snd_emu10k1x
 1 snd_hda_intel
 2 snd_hda_intel
[[email protected] ~]$

@ufuk, çıktı artık bu şekilde. Yardımların için teşekkür ederim.
Fakat, bilgisayarı yeniden başlattığım zaman ses alabilmek için Pulseaudio Ses Denetimi'nden yine seçim yapmak zorunda kalıyorum.

Çevrimdışı ufuk

  • Yeni Üye
  • *
  • İleti: 49
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #7 : 26 Temmuz 2013, 06:23:39 »
Hdmi çıkışı kullanmıyorsanız listeden silin?
Kod: [Seç]
options snd slots=snd_emu10k1x
options snd_emu10k1x index=0

Çevrimdışı 1910

  • Yeni Üye
  • *
  • İleti: 8
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #8 : 26 Temmuz 2013, 07:45:54 »
Son söylediğinizi uyguladım. Bir değişiklik olmadı.



Resimini de koyayım.. Alttakini seçerek, sesi alabiliyorum.

Çevrimdışı ufuk

  • Yeni Üye
  • *
  • İleti: 49
  • Teşekkür: +0/-0
Re: Ses Kartı Sorunu
« Yanıtla #9 : 26 Temmuz 2013, 11:30:00 »
Pulseaudio'yu devreden çıkarın. "Oturum ve başlangıç"ta "başlangıçta çalıştırma"dan pulseaudio'nun işaretini kaldırın. Yeniden başlatınca ses gelmezse tekrar işaretlersiniz ve aynı yere "Ekle" deyip herhangi bir isimle bu komutu
Kod: [Seç]
rm -rf ~/.pulse ~/.config/pulse && killall pulseaudioçalıştıktan sonra kapatmayı sağlamış olursunuz. Kusura bakmayın uğraştırıyorum.