Gönderen Konu: =>FFmpeg convert sorunu  (Okunma sayısı 1687 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı xspacex

  • Yeni Üye
  • *
  • İleti: 35
  • Teşekkür: +0/-0
=>FFmpeg convert sorunu
« : 02 Temmuz 2013, 07:58:05 »
Herkese iyi günler...
FFmpeg ile video çevirmeye çalıştığımda şu hatayı alıyorum;
Kodları Mobile Media Converter isimli yazılım oluşturdu...
Sistemim 32-bit Manjaro XFCE.
Kod: [Seç]
[[email protected] xspacex]# ffmpeg -y -i "/home/xspacex/Downloads/video.avi"  -vf scale=352:288 -f 3gp -vcodec h263 -r 25 -b 320k -acodec libvo_aacenc -ac 2 -ar 41000 -ab 96k "/home/xspacex/Downloads/video.3gp"
ffmpeg version 1.2.1 Copyright (c) 2000-2013 the FFmpeg developers
  built on May 10 2013 16:37:54 with gcc 4.8.0 (GCC) 20130502 (prerelease)
  configuration: --prefix=/usr --disable-debug --disable-static --enable-avresample --enable-dxva2 --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-postproc --enable-runtime-cpudetect --enable-shared --enable-vdpau --enable-version3 --enable-x11grab
  libavutil      52. 18.100 / 52. 18.100
  libavcodec     54. 92.100 / 54. 92.100
  libavformat    54. 63.104 / 54. 63.104
  libavdevice    54.  3.103 / 54.  3.103
  libavfilter     3. 42.103 /  3. 42.103
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
[avi @ 0x9cdf4e0] non-interleaved AVI
Input #0, avi, from '/home/xspacex/Downloads/video.avi':
  Metadata:
    encoder         : AVI-Mux GUI 1.17.8.3, Feb 16 201019:42:50o
    JUNK            :
  Duration: 01:44:46.68, start: 0.000000, bitrate: 1030 kb/s
    Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 704x368 [SAR 1:1 DAR 44:23], 25 tbr, 25 tbn, 25 tbc
    Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, s16p, 128 kb/s
    Metadata:
      title           : Romantik.128Kbs
Please use -b:a or -b:v, -b is ambiguous
Unknown encoder 'libvo_aacenc'
Hatadaki çıktıda yer alan
Kod: [Seç]
--prefix=/usr komutunda hata veriyor...
Sorunu nasıl çözebilirm? Teşekkürler...

Çevrimdışı cumali

  • Gelişmiş Üye
  • *****
  • İleti: 1785
  • Teşekkür: +2/-0
  • Dağıtım / Distribution: Manjaro Linux
  • Masaüstü / Desktop Environment: Openbox
  • Ekran Kartı - Graphic Card: INTEL
  • Ekr. Kartı Sür. Graph.Dri: Sahipli yazılım
Re: =>FFmpeg convert sorunu
« Yanıtla #1 : 02 Temmuz 2013, 08:11:49 »
Bahsi geçen yazılım mobilemediaconverter Aurda yer almakta ve güncelligini yitirmiş durumdadır. https://aur.archlinux.org/packages/mobilemediaconverter/?setlang=tr  Aynı işlevi yerine getirebilecek farklı bir uygulamayı araştırın. Örnegin; winff işinizi görürmü bilmiyorum. https://www.archlinux.org/packages/community/i686/winff/

Çevrimdışı xspacex

  • Yeni Üye
  • *
  • İleti: 35
  • Teşekkür: +0/-0
Re: =>FFmpeg convert sorunu
« Yanıtla #2 : 02 Temmuz 2013, 08:14:14 »
Şuan sistemimde güncel sürüm kurulu PKGBUILD dosyasını düzenleyerek güncel sürümünü sistemime derledim.

Çevrimdışı xspacex

  • Yeni Üye
  • *
  • İleti: 35
  • Teşekkür: +0/-0
Re: =>FFmpeg convert sorunu
« Yanıtla #3 : 02 Temmuz 2013, 22:13:33 »
Winff ilede olmuyor sanırım sorun bazı ayarların "enable" olmaması... Ama çıktıdaki komutu uygulayamıyorum... Çıktıdaki komutları nasıl uygulayabilirim. Çıktı şöyle;
Kod: [Seç]
[[email protected] xspacex]# ffmpeg
ffmpeg version 1.2.1 Copyright (c) 2000-2013 the FFmpeg developers
  built on May 10 2013 16:37:54 with gcc 4.8.0 (GCC) 20130502 (prerelease)
  configuration: --prefix=/usr --disable-debug --disable-static --enable-avresample --enable-dxva2 --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-postproc --enable-runtime-cpudetect --enable-shared --enable-vdpau --enable-version3 --enable-x11grab
  libavutil      52. 18.100 / 52. 18.100
  libavcodec     54. 92.100 / 54. 92.100
  libavformat    54. 63.104 / 54. 63.104
  libavdevice    54.  3.103 / 54.  3.103
  libavfilter     3. 42.103 /  3. 42.103
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
Hata çıktısı şöyle;
Kod: [Seç]
[[email protected] xspacex]# --prefix=/usr --disable-debug --disable-static --enable-avresample --enable-dxva2 --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-postproc --enable-runtime-cpudetect --enable-shared --enable-vdpau --enable-version3 --enable-x11grab
bash: --prefix=/usr: Böyle bir dosya ya da dizin yok