Archman GNU/Linux - Arch Linux ve Türevleri - Manjaro - Antergos Türkiye

GENEL KATEGORİ (ORTAK KONULAR) => TEKNİK DESTEK => ARCHMAN OS => Konuyu başlatan: asukaki - 02 Mayıs 2019, 23:18:34

Başlık: [Çözüldü]Bumblebee kurulumda sorun
Gönderen: asukaki - 02 Mayıs 2019, 23:18:34
Archman Xfce güncel son sürüm kullanıyorum.

http://archman.org/forum/index.php?topic=2151.0 burada anlatılanlar olduğu gibi yaptım ve ta ki
Kod: [Seç]
groups komutuna gelene kada bu komutta bende şöyle bir çıktı veriyor
Kod: [Seç]
[[email protected] ~]$ groups
bumblebee network users video storage lp audio wheel sambashare asukaki
Kod: [Seç]
[[email protected] ~]$ systemctl status bumblebeed
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor >
   Active: active (running) since Thu 2019-05-02 22:59:56 +03; 16min ago
 Main PID: 550 (bumblebeed)
    Tasks: 1 (limit: 4603)
   Memory: 12.9M
   CGroup: /system.slice/bumblebeed.service
           └─550 /usr/bin/bumblebeed

May 02 22:59:56 gguntepe systemd[1]: Started Bumblebee C Daemon.
May 02 22:59:57 gguntepe bumblebeed[550]: [   14.141703] [INFO]/usr/bin/bumbleb>
May 02 23:09:34 gguntepe bumblebeed[550]: modprobe: ERROR: could not insert 'nv>
May 02 23:09:34 gguntepe bumblebeed[550]: [  591.830681] [ERROR]Module nvidia c>
May 02 23:09:34 gguntepe bumblebeed[550]: [  591.830740] [ERROR]Could not load >
lines 1-14/14 (END)
Kod: [Seç]
glxspheres64 normal şekilde gösterim yapıyor
Kod: [Seç]
optirun glxspheres64 bu komutta
Kod: [Seç]
[ 1052.055188] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 1052.055320] [ERROR]Aborting because fallback start is disabled.
[[email protected] ~]$

ben ikisini değilde sadece nvidia kullansam
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: asukaki - 06 Mayıs 2019, 12:49:53
Normal bir durum mu ?
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: tulliana - 07 Mayıs 2019, 14:03:41
Normal bir durum değil, sisteminizi güncelleyin. Sorun devam ediyorsa Bumblebee kurulum dökümanını yeniden uygulayın
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: asukaki - 08 Mayıs 2019, 00:43:24
Yeniden uyguladım ama aynı yerde yine
Kod: [Seç]
optirun glxspheres64 komutu verdiğimde yine aynı hatayı aıyorum.
İnternette bir iki bir düzeltme vardı fakat sonucu değiştirmedi. Aynı bilgisayarda daha önce normal kurulmuştu.
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: tulliana - 09 Mayıs 2019, 09:09:54
Kod: [Seç]
lspci | grep -E "VGA|3D"
uname -a
çıktıları nedir?
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: asukaki - 11 Mayıs 2019, 12:48:17
Kod: [Seç]
[[email protected] ~]$ lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF116M [GeForce GT 555M/635M] (rev ff)
[[email protected] ~]$ uname -a
Linux gguntepe 5.0.13-arch1-1-ARCH #1 SMP PREEMPT Sun May 5 18:05:41 UTC 2019 x86_64 GNU/Linux
[[email protected] ~]$
bu şekilde
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: asukaki - 14 Mayıs 2019, 22:53:02
2019,05 güncellemesinden sonra da aynı şekilde devam ediyor.
Kod: [Seç]
[[email protected] ~]$ optirun glxspheres64
[  154.688931] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  154.689058] [ERROR]Aborting because fallback start is disabled.
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: tulliana - 14 Mayıs 2019, 23:56:52
Nvidia fermi tabanlı gpu kullanıyorsunuz, bumblebee belgesini uygularken buna dikkat edin. Uygun sürücüyü yükleyin. Yüklediklerinizi kaldırın ve aşağıdaki detaya dikkat ederek tekrar yükleyin.

http://archman.org/forum/index.php?topic=2151.0

bağlantıdaki belgeyi uygulayacaksınız ve kırmızı font ile vurguladığımız satır sizin GPU için uygun olan, yani;
Kod: [Seç]
sudo pacman -S bumblebee mesa xf86-video-intel nvidia-390xx lib32-nvidia-390xx-utils bbswitch nvidia-390xx-utils
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: asukaki - 28 Mayıs 2019, 22:57:01
Bazı nedenlerden yeniden kurulum yaptım ve sizin dediğiniz şekilde uyguladım kırmızı belirtilen satırı da uygulamama rağmen yine sonuç değişmedi.
Kod: [Seç]
[[email protected] ~]$ optirun glxspheres64
[ 1853.612280] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1853.612368] [ERROR]Could not connect to bumblebee daemon - is it running?

Ayrıca ondan önce çıktılarımız şöyle farklı çıkıyor sizin belirttiğinizden
Kod: [Seç]
[[email protected] ~]$ groups
network users video storage lp audio wheel sambashare gguntepe
bu benim çıktım sizin gösterdiğiniz de farklı çıkıyor.

Ayrıca şimdi bazen bu şekilde kurulum yapmaya çalıştığımızda bazen son adımda hata oluyor ve uygulayamıyoruz. Bu işlemleri geri almamızın bir yolu var mı ? hem bunun için hemde bu şekildeki kurulumlar için

Kod: [Seç]
pacman -R ile yüklenenleri geri mi alacağız yoksa farklı bir yol mu ?
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: alicavus - 29 Mayıs 2019, 10:39:09
Şuradan (https://wiki.archlinux.org/index.php/bumblebee) edinilen bilgiye göre:

1. Kullanıcımızın bumblebee grubuna dahil olması lazım:
Kod: [Seç]
sudo gpasswd -a $USER bumblebee
2. bumblebeed servisinin (daemon) çalışır olması gerekir. Açılışta çalıştırmak için:
Kod: [Seç]
sudo systemctl enable bumblebeed.servicekomutunu kullanıyoruz.

Servisi elle de çalıştırabiliriz:
Kod: [Seç]
sudo systemctl start bumblebeed.service
3. İlkyükledikten sonra sistemi yeniden başlatıyoruz. Unix sistemlerde reboot etme şart değildir, ancak sonkullanıcı için uygun olan budur, neticede herhangi servisin diğer servislerle olan ilişkisine hakim olmadan gerekli ayarlamaları yapmazsak hatalı çalışmasına sebep olabiliriz.
Başlık: Ynt: Bumblebee kurulumda sorun
Gönderen: tulliana - 29 Mayıs 2019, 13:59:56
http://archman.org/forum/index.php?topic=2151.0 belgemizde de aynı yol mevzu bahistir

Arch Linux'ta Intel/Nvidia hibrit kart kurulumu ve Bumblebee (Optimus)

paketleri yükledikten sonra, kullanıcımızı bumblebee grubuna dahil ederek yetkilendirelim
Kod: [Seç]
sudo gpasswd -a $USER bumblebee

Şimdi de bumblebee servisini, sistem açılırken çalışması için etkinleştirelim
Kod: [Seç]
sudo systemctl enable bumblebeed.service
ardından bilgisayarınızı yeniden başlatın ya da uçbirimden sudo reboot komutunu verin.

Başlık: Ynt: [Çözüldü]Bumblebee kurulumda sorun
Gönderen: asukaki - 30 Mayıs 2019, 01:12:43
Evet belgede de  mevcut aynı durum,  elle aur depolarını aktif edip denedikten sonra sorun ortadan kalktı. Alakası var mı bilmiyorum ama şuan sorunsuz çalışıyor.